Topic summary
JMAP
Extracted from the Wikipedia article JSON Meta Application Protocol.
Development
JMAP started around 2014 as an internal development project by the Australian-based email provider Fastmail. Starting in 2017 a working group at the IETF has been leading the development and standardization process. The core protocol and mail specifications were published in July and August 2019 by Neil Jenkins of Fastmail and Chris Newman of Oracle, as RFC 8620 and RFC 8621. The WebSocket specification was later published in August 2020 as RFC 8887, and Message Disposition Notification (return receipts) in March 2021 as RFC 9007.