Topic summary
HOSTS.TXT

Extracted from the Wikipedia article Hosts (file).
History
The earliest effort to standardize host naming was proposed in 1971 by Peggy Karp of MITRE, who published RFC 226, defining a standard set of host mnemonics mapping network addresses to human-readable names. Karp's list has been described as the first hosts.txt file, the predecessor of the modern root file. Later standardization efforts, such as the format specification of the file HOSTS.TXT in RFC 952, and distribution protocols, e.g., the hostname server described in RFC 953, helped with these problems, but the centralized and monolithic nature of hosts files eventually necessitated the creation of the distributed Domain Name System (DNS).