Topic summary
DS field
Extracted from the Wikipedia article Differentiated services.
DiffServ RFCs
- RFC 2474 — Definition of the differentiated services field (DS field) in the IPv4 and IPv6 headers. Note that the DS field of 8 bits (the bottom two unused) in was later split into the current 6-bit DS field and a separate 2-bit ECN field.
- RFC 2475 — An architecture for differentiated services.
- RFC 2597 — Assured forwarding PHB group.
- RFC 2983 — Differentiated services and tunnels.
- RFC 3086 — Definition of differentiated services per-domain behaviors and rules for their specification.
- RFC 3140 — Per hop behavior identification codes. (Obsoletes RFC 2836.
- RFC 3246 — An expedited forwarding PHB. (Obsoletes RFC 2598.)
- RFC 3247 — Supplemental information for the new definition of the EF PHB (expedited forwarding per-hop behavior).
- RFC 3260 — New Terminology and Clarifications for Diffserv. (Updates RFC 2474, RFC 2475 and RFC 2597.)
- RFC 4594 — Configuration Guidelines for DiffServ Service Classes.
- RFC 5865 — A differentiated services code point (DSCP) for capacity-admitted traffic. (Updates RFC 4542 and RFC 4594.)
- RFC 8622 — A Lower-Effort Per-Hop Behavior (LE PHB) for Differentiated Services. (Updates RFC 4594 and RFC 8325, obsoletes RFC 3662.)