Topic summary
Computer protocol

Extracted from the Wikipedia article Communication protocol.
Bibliography
- Radia Perlman (1999). Interconnections: Bridges, Routers, Switches, and Internetworking Protocols (2nd ed.). Addison-Wesley. ISBN .. In particular Ch. 18 on "network design folklore", which is also available online
- Gerard J. Holzmann (1991). Design and Validation of Computer Protocols. Prentice Hall. ISBN .
- Douglas E. Comer (2000). Internetworking with TCP/IP - Principles, Protocols and Architecture (4th ed.). Prentice Hall. ISBN . In particular Ch.11 Protocol layering. Also has a RFC guide and a Glossary of Internetworking Terms and Abbreviations.
- R. Braden, ed. (1989). Requirements for Internet Hosts -- Communication Layers. Internet Engineering Task Force abbr. IETF. doi:10.17487/RFC1122. RFC 1122. Describes TCP/IP to the implementors of protocol software. In particular, the introduction gives an overview of the design goals of the suite.
- M. Ben-ari (1982). Principles of concurrent programming (10th Print ed.). Prentice Hall International. ISBN .
- C.A.R. Hoare (1985). Communicating sequential processes (10th Print ed.). Prentice Hall International. ISBN .
- R.D. Tennent (1981). Principles of programming languages (10th Print ed.). Prentice Hall International. ISBN .
- Brian W Marsden (1986). Communication network protocols (2nd ed.). Chartwell Bratt. ISBN .
- Andrew S. Tanenbaum (1984). Structured computer organization (10th Print ed.). Prentice Hall International. ISBN .
- Bryant, Stewart; Morrow, Monique, eds. (November 2009). Uncoordinated Protocol Development Considered Harmful. IETF. doi:10.17487/RFC5704. RFC 5704.
- Farrell, Stephen; Tschofenig, Hannes (May 2014). Pervasive Monitoring Is an Attack. IETF. doi:10.17487/RFC7258. RFC 7258.
- Trammell, Brian; Kuehlewind, Mirja (April 2019). The Wire Image of a Network Protocol. IETF. doi:10.17487/RFC8546. RFC 8546.
- Hardie, Ted, ed. (April 2019). Transport Protocol Path Signals. IETF. doi:10.17487/RFC8558. RFC 8558.
- Fairhurst, Gorry; Perkins, Colin (July 2021). Considerations around Transport Header Confidentiality, Network Operations, and the Evolution of Internet Transport Protocols. IETF. doi:10.17487/RFC9065. RFC 9065.
- Thomson, Martin; Pauly, Tommy (December 2021). Long-Term Viability of Protocol Extension Mechanisms. IETF. doi:10.17487/RFC9170. RFC 9170.
- Arkko, Jari; Hardie, Ted; Pauly, Tommy; Kühlewind, Mirja (July 2023). Considerations on Application - Network Collaboration Using Path Signals. IETF. doi:10.17487/RFC9419. RFC 9419.
- McQuistin, Stephen; Perkins, Colin; Fayed, Marwan (July 2016). Implementing Real-Time Transport Services over an Ossified Network. 2016 Applied Networking Research Workshop. doi:10.1145/2959424.2959443. hdl:1893/26111.
- Papastergiou, Giorgos; Fairhurst, Gorry; Ros, David; Brunstrom, Anna; Grinnemo, Karl-Johan; Hurtig, Per; Khademi, Naeem; Tüxen, Michael; Welzl, Michael; Damjanovic, Dragana; Mangiante, Simone (2017). "De-Ossifying the Internet Transport Layer: A Survey and Future Perspectives". IEEE Communications Surveys & Tutorials. 19: 619–639. doi:10.1109/COMST.2016.2626780. hdl:2164/8317.
- Moschovitis, Christos J. P. (1999). History of the Internet: A Chronology, 1843 to the Present. ABC-CLIO. ISBN .