TheInfoListRev V5.1.84
Xfr/
SummaryRelatedTreeNews

Related topics

Message transfer agent

Within the Internet email system, a message transfer agent (MTA), mail transfer agent, or mail relay is software that transfers electronic mail messages from one computer to another using the Simple Mail Transfer Protocol. In some contexts, the alternative names mail server, mail exchanger, or MX host are used to describe an MTA. Messages exchanged across networks are passed between mail servers, including any attached data files (such as images, multimedia, or documents).

Internet Message Access ProtocolInternet Message Access ProtocolIn computing, the Internet Message Access Protocol (IMAP) is an Internet standardprotocol used by email clients to retrieve email messages from a mail server over a TCP/IP connection. IMAP is defined by RFC9051. IMAP was designed with the goal of permitting complete management of an email box by multiple email clients; therefore, clients generally leave messages on the server until the user explicitly deletes them. An IMAP server typically listens on port number 143.Simple Mail Transfer ProtocolSimple Mail Transfer ProtocolThe Simple Mail Transfer Protocol (SMTP) is an Internet standardcommunication protocol for electronic mail transmission. Mail servers and other message transfer agents use SMTP to send and receive mail messages. User-level email clients typically use SMTP only for sending messages to a mail server for relaying, and typically submit outgoing email to the mail server on port 465 or 587 per RFC8314.Email clientEmail clientAn email client, email reader, message user agent (MUA), or mail user agent is a computer program used to access and manage a user's email. A web application which provides message management, composition, and reception functions may act as a webmail client, and a piece of computer hardware or software whose primary or most visible role is to work as an email client may also use the term.Message delivery agentA message delivery agent (MDA) or mail delivery agent is a computer software component that is responsible for the delivery of email messages to a local recipient's mailbox. It is also called a local delivery agent (LDA). Within the Internet mail architecture, local message delivery is achieved through a process of handling messages from the message transfer agent, and storing mail into the recipient's environment (typically a mailbox).Email boxEmail boxA mailbox (also electronic mailbox, email box, email mailbox, e-mailbox) is the destination to which electronic mail messages are delivered. It is the equivalent of a letter box in the postal system. DefinitionsA mailbox is identified by an email address. However, not all email addresses correspond to a storage facility. The term pseudo-mailbox is sometimes used to refer to an address that does not correspond to a definitive mail store.EmailEmailElectronic mail (usually shortened to email; alternatively hyphenated e-mail) is a method of transmitting and receiving digital messages using electronic devices over a computer network. It was conceived in the late–20th century as the digital version of, or counterpart to, mail (hence e- + mail).Post Office ProtocolPost Office ProtocolFamily of Internet mail protocols Post Office ProtocolCommunication protocolOSI layerApplication layerIP numberTCPPorts110 (unencrypted)995 (secured over TLS/SSL)RFCs1939 (Current)2449 (Extension Mechanism)5034 (SASL Authentication) In computing, the Post Office Protocol (POP) is an application-layer Internet standard protocol used by e-mail clients to retrieve e-mail from a mail server. Today, POP version 3 (POP3) is the most commonly used version.MAPIMessaging Application Programming Interface (MAPI) is an API for Microsoft Windows which allows programs to become email-aware. While MAPI is designed to be independent of the protocol, it is usually used to communicate with Microsoft Exchange Server. DetailsMAPI uses functions loosely based on the X.400 XAPIA standard. It includes facilities to access message transports, message stores, and directories.Message submission agentMessage submission agentA message submission agent (MSA) or mail submission agent is a computer program or software agent that receives electronic mail messages from a mail user agent (MUA) and cooperates with a mail transfer agent (MTA) for delivery of the mail. It uses ESMTP, a variant of the Simple Mail Transfer Protocol (SMTP), as specified in RFC 6409.SoftwareSoftwareSoftware (SW) consists of computer programs that instruct the execution of a computer. Software also includes design documents and specifications. The history of software is closely tied to the development of digital computers in the mid-20th century. Early programs were written in the machine language specific to the hardware.WebmailWebmailWebmail (or web-based email) is an email service that can be accessed using a standard web browser. It contrasts with email service accessible through a specialised email client software. Additionally, many internet service providers (ISP) provide webmail as part of their internet service package. Similarly, some web hosting providers also provide webmail as a part of their hosting package.Request for CommentsRequest for CommentsA Request for Comments (RFC) is a publication in a series from the principal technical development and standards-setting bodies for the Internet, most prominently the Internet Engineering Task Force (IETF). An RFC is authored by individuals or groups of engineers and computer scientists in the form of a memorandum describing methods, behaviors, research, or innovations applicable to the working of the Internet and Internet-connected systems.

*As an Amazon Associate I earn from qualifying purchases.

AboutPrivacyContact

TheInfoList organizes topic information and links to original sources.

Loading topic…